Samsung’s TLC NAND 840 EVO SSDs affected by bug – firmware update near

Posted 25 September 2014 13:21 CEST by Jan Willem Aldershoff

Owners of Samsung’s 840 EVO SSDs report speed issues with their drives. The users found that files that were recently written to the disk were read at full speed (450 MB/s), however files that were written to the disk longer ago, were read with a 100MB/s or less.

myce-samsung-840-evo-speed-issue

The problem was demonstrated with HD Tach, benchmark software that is able to read out the entire disk. The benchmark clearly shows that the sequential read speed of older data varies a lot, while the read speed of recently written files continuously stays at the same level.

Samsung has stated it is aware of the problem and that it works on a firmware update to fix the problems. The company expect the update will be read mid October.

Discuss this in our SSD Forum



Reactions closed

Sorry, you can't comment on this item anymore. It's either too old or comments are disabled for this post.

Myce.com settings

Several settings at Myce.com can be changed, they are stored in cookies, which means they will be reset if you clear Myce.com cookies

Background

Change the background to a plain color or trianglified image (similar to the default image)

No tracking features

At Myce most social media feature are done server side and impose no privacy risk to the visitor when not used. Several features use Javascript with you can turn off here

Layout

Switch to the List layout for an index with chronologycally listed news items or Grid layout for a block based layout. To see the change you need to reload the page

×